[NEWSboard IBMi Forum]
Seite 2 von 2 Erste 1 2
  1. #13
    Registriert seit
    Dec 2009
    Beiträge
    291
    Zitat Zitat von Chris.jan Beitrag anzeigen
    Probleme dieser Art kommen auch gerne autoamtisiert durch Windows-Updates weil der Wechsel von SMB1 auf SMB2 bei Windows vollzogen wird und bei der AS/400 noch angepasst werden muss.
    Dazu mal ein link auf die dazugehörige Technote: https://www-01.ibm.com/support/docvi...d=nas8N1022198

    Ich hab neulich einen Workaround gebaut weil ich solche Probleme einfach grundsätzlich los werden wollte. Also erst ins IFS (CCSID nicht vergessen) und dann per SCP rüber auf jeden beliebigen Server.
    OpenSSH ist schnell installiert, ab WinServer2019 sogar als optionales Feature dabei.
    Hallo,
    hättest vielleicht ein Beispiel wenn möglich in einem CL
    Danke im voraus
    Andreas
    Ein AS/400 Dinosaurier since 1989

  2. #14
    Registriert seit
    Feb 2009
    Beiträge
    378
    Hie rmal das Beispiel... Ich hoffe ich hab nix vergessen...
    in ID steht die Dtaei mit dem public-ssh-key
    Code:
    CCSID:      CHGVAR     VAR(&CMD) VALUE('touch -C 850' *BCAT &PATH +  
                             *TCAT &FILE)                                
                QSH        CMD(&CMD)                                     
                CHGVAR     VAR(&CMD) VALUE('echo "test" >>' *BCAT &PATH +   
                             *TCAT &FILE)                                
                QSH        CMD(&CMD)                                     
     COPY:       CHGVAR     VAR(&CMD) VALUE('scp' *BCAT &ID *BCAT &PATH + 
                              *TCAT &FILE *BCAT +                         
                              'user@hostname:/home/user')     
                 QSH        CMD(&CMD)

Ähnliche Themen

  1. Windows Share Freigabe in CL
    Von Hanuta im Forum IBM i Hauptforum
    Antworten: 3
    Letzter Beitrag: 21-12-17, 09:34
  2. Problem beim Aufruf wsdl2ws.sh
    Von svit im Forum NEWSboard Programmierung
    Antworten: 5
    Letzter Beitrag: 23-01-17, 11:27
  3. Problem beim CPYTOIMPF
    Von Paul_Hofmann im Forum NEWSboard Programmierung
    Antworten: 4
    Letzter Beitrag: 23-09-15, 12:41
  4. Problem beim Laden von PTF SF65630
    Von Kent im Forum IBM i Hauptforum
    Antworten: 0
    Letzter Beitrag: 15-11-01, 10:59
  5. Problem beim Autostart von Client Access Druckersessions
    Von Rukober im Forum NEWSboard Drucker
    Antworten: 4
    Letzter Beitrag: 17-09-01, 08:58

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •