[NEWSboard IBMi Forum]
  1. #1
    Registriert seit
    Oct 2014
    Beiträge
    28

    Netzlaufwerk verbinden

    Hallöchen!

    Auf unserer iSeries wurde bei einem Laufwerk die Zugriffsberechtigung von *PUBLIC auf *NONE gestellt und nur für gewisse User ein *RWX Eintrag erfasst.

    Zuvor wurde das Netzlaufwerk für die entsprechenden User mit einem Allgemeinen User ohne Kennwortablauf eingerichtet. Daher konnte man bei jedem User die Verknüpfung über diesen einen User einrichten.

    Nun ist es aber so, dass diese speziellen User nicht mehr auf das IFS Laufwerk kommen. Wenn ich unter Windows das Laufwerk hinzufügen will kommt nach Angabe des Laufwerkbuchstabens und der Eingabe des Ordner im format \\ip-adresse\XYZ die Abfrage des Benutzers. Hier gebe ich, um die AD Anmeldung mit dem Windows User zu vermeiden, im Feld Benutzer die Adresse des Servers, einen Backslash und den iSeries Benutzernamen an. Im Kennwortfeld dann das iSeries Kennwort. Danach erscheint eine Fehlermeldung :
    Code:
    ---------------------------
    Windows
    ---------------------------
    Dieser Netzwerkordner ist zurzeit unter Verwendung eines anderen Namens und Kennwortes verbunden.
    
    Trennen Sie zuerst jede bestehende Verbindung auf diese Netzwerkfreigabe, um unter Verwendung eines anderen Namens und Kennwortes verbunden zu werden.
    ---------------------------
    OK   
    ---------------------------
    Kann mir da wer helfen? Was kann man in dem Fall machen?

    PS: Zu der Fehlermeldung ist zu sagen, dass ich auf meinem Rechner z.B. (ich hab für meinen User einen Eintrag in die Zugriffsberechtigungen eingerichtet) keine einzige Verbindung mehr auf die iSeries zeigt. Es gibt zwar Netzlaufwerke, aber diese zeigen auf Windows-Server. Daher kann ich auch nicht nachvollziehen, warum dieser eine Netzlaufordner unter anderen Credentials bereits verbunden ist.

  2. #2
    Registriert seit
    May 2002
    Beiträge
    1.076
    Hi,

    gib mal in einen CMD-Fenster

    NET USE

    ein.

    Hier sollte dann eine Liste der verbundenen Laufwerke kommen.
    Wenn du eins trenn willst, dann

    NET USE \\mein_Server\blba /DELETE

    Das Sollte das Laufwerk trennen.

    Danach solltest du dich mit einen Neuen Namen verbinden können

    Gruß
    Ronald

  3. #3
    Registriert seit
    Oct 2014
    Beiträge
    28
    Danke für die fixe Antwort

    Leider hat das nicht funktioniert...
    Ich habe zwischendurch herausgefunden, dass sich Windows irgendwie, irgendwo noch die Anmeldedaten speichert. Wenn ich zum Testen den ursprünglichen Allgemein-User in die Liste der erlaubten User für das Netzlaufwerk mitaufnehme und auf meiner Kiste auf das Laufwerk zugreifen bzw ein Netzlaufwerk verbinden will, dann funktioniert es wieder. Sobald ich aber dem User den Zugriff wieder abdrehe, zeigt mir Windows an, dass ich keine Berechtigung habe auf das Laufwerk zuzugreifen.

    Es wird mir, obwohl die Meldung mit dem "Bereits angemeldet" kommt, weder in der CMD, noch im Windows Explorer eine Verknüpfung zur iSeries angezeigt.

  4. #4
    Registriert seit
    Feb 2001
    Beiträge
    18.168
    Ruf mal "Windows->Netzwerkkennwörter verwalten" auf.
    Da kannst du gespeicherte Kennwörter entfernen.
    Dienstleistungen? Die gibt es hier: http://www.fuerchau.de
    Das Excel-AddIn: http://www.fuerchau.de/software/upload400.htm
    BI? Da war doch noch was: http://www.ftsolutions.de

  5. #5
    Registriert seit
    Oct 2014
    Beiträge
    28
    Also mit einem (einzigen) User hat es dann doch noch funktioniert.
    Hab zum einen im WRKLNK über die Option 9 den Zugriff gewährt und für den User den bestehenden WRKDIRE Eintrag mit 2 geöffnet und gleich wieder mit Enter bestätigt.
    Anschließend in Windows über NET USE * /DELETE alle Verknüpfungen gelöscht und nur diejenigen, die ich brauche mit NET USE X: \\server\verzeichnis /user:user-name und anschließender Angabe des Kennwortes wieder hinzugefügt.

    Beim zweiten User hab ich die tolle Eigenheit, dass ich den Account an sich nicht über NET USE X: \\server\verzeichnis /user:user-name und Kennwort hinzufügen kann. Da kommt dann immer die Fehlermeldung Systemfehler 5 (Zugriff verweigert). Wenn ich den speziellen User über WRKUSRPRF mit Option 3 kopiere und aus (nur als Beispiel) TEST den User TEST2 mache, in WRKLNK den Berechtigungseintrag erfasse und in WRKDIRE für den User einen Eintrag anlege und sonst nichts ändere, dann kann ich ganz bequem ohne Fehlermeldung mit NET USE X: \\server\verzeichnis /user:TEST2 und Kennwort die Verknüfung hinzufügen.

    Und das Verhalten hat sich nicht nur an meinem Rechner gezeigt, sondern auch am PC meines Kollegen. Es muss irgendetwas mit dem User an sich zu tun haben. Zum Testen davor hab ich einen Dummy Account angelegt und wie oben genannt die entsprechenden Einträge verfasst. Wollte wissen/ausschließen, ob der Access Denied Fehler an den Berechtigungen im *USRPRF liegt. Der hat am Anfang ganz normal funktioniert (also das Laufwerk hat sich mit Angabe der Credentials des Test-Users ganz einfach anlegen lassen). Nachdem ich für den Test User im WRKLNK den Eintrag gelöscht habe, ließ sich auch im Windows logischerweise für den User kein Laufwerk mehr anlegen. Nachdem ich den Eintrag wieder hinzugefügt habe, bekam ich für den Test User die selbe Fehlermeldung, wie ich sie weiter oben beschrieben habe. Darauf den User kopiert und wieder Einträge verfasst und schon funzte es mit NET USE und /user:TEST2

    Aaarg... Gott sei Dank ist WE.
    Hoff ich komm am Montag drauf.

  6. #6
    Registriert seit
    Feb 2001
    Beiträge
    18.168
    Nun, der NetServer der AS/400 verwaltet leider noch eine eigene Liste gesperrter User.
    Bei CA kann man den NetServer über die iSeries Navigator starten und dort die Liste der gesperrten User löschen.
    Beim neuen Director weiß ich das nicht.
    WRKDIRE ist für IFS-Zugriffe (außer QDLS) nicht erforderlich.
    Dienstleistungen? Die gibt es hier: http://www.fuerchau.de
    Das Excel-AddIn: http://www.fuerchau.de/software/upload400.htm
    BI? Da war doch noch was: http://www.ftsolutions.de

Ähnliche Themen

  1. Netzlaufwerk erstellen
    Von alex61 im Forum IBM i Hauptforum
    Antworten: 3
    Letzter Beitrag: 26-02-19, 18:22
  2. AS400 Ordner als Netzlaufwerk verbinden
    Von ensöianer im Forum IBM i Hauptforum
    Antworten: 8
    Letzter Beitrag: 26-01-15, 13:05
  3. 2 PF-Dateien verbinden
    Von Hans Zuther im Forum IBM i Hauptforum
    Antworten: 6
    Letzter Beitrag: 15-05-03, 15:38
  4. Client Access Express - Netzlaufwerk verbinden
    Von cassandra im Forum IBM i Hauptforum
    Antworten: 7
    Letzter Beitrag: 20-11-02, 10:52
  5. CA/Express und WIN98 SE: Netzlaufwerk
    Von GfD im Forum NEWSboard Server Software
    Antworten: 2
    Letzter Beitrag: 13-11-02, 08:35

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •