[NEWSboard IBMi Forum]
  1. #1
    Registriert seit
    Feb 2017
    Beiträge
    15

    Zend Server 2019 Lizenzierung

    Hallo,

    wir planen unseren Zend Servers 8.5.7 auf die aktuelle Version Zend Server 2019 mit PHP 7 zu bringen.
    Bisher war es ja immer so, das man als IBM i Nutzer initial 12 Monate Basic Subscription bekommt, anschließend den Zend Server aber weiter nutzen konnte ohne Support.
    Kann sich das mit der Version 2019 verändert haben? Ein Verkäufer von Zend / Perforce hat mir gesagt das ich jetzt eine Lizenz erwerben müsste, da sich die Vereinbarung zwischen IBM und Zend geändert hat. Die IBM Support Seite wurde ebenfalls aktualisiert: https://www.ibm.com/support/pages/ze...rt-information

    Hat hier schon jemand die aktuelle Zend Server Version im Einsatz?

    Gruß,
    Manuel

  2. #2
    Registriert seit
    Aug 2003
    Beiträge
    1.429
    Hi Manuel,

    du kannst den aktuellen Zend Server auf der IBM i installieren und nützen, jedoch Support gibt es nur wenn man direkt bei Zend diesen bestellt.

    lg Andreas

  3. #3
    Registriert seit
    Feb 2017
    Beiträge
    15
    Hallo Andreas,

    danke für die Antwort. Das beruhigt mich doch, hatte schon die Befürchtung das wir jetzt eine Lizenz erwerben müssen für das bisschen PHP was wir machen und um das aktuelle PHP zu nutzen.

    Danke & Gruß,
    Manuel

  4. #4
    Registriert seit
    Aug 2003
    Beiträge
    1.429
    Das schöne bei der Update Variante ist, dass man die Updates auch wieder gut entfernen lassen kann.
    Bzw. zwischen den php Versionen 7.1, 7.2 und 7.3 switchen kann, falls es mit Anwendungen probleme gibt.

  5. #5
    Registriert seit
    Feb 2017
    Beiträge
    15
    Ja, bei php 7.2 und 7.3 gibt es aktuell noch Probleme mit dem von Zend ausgelieferten ibm_db2. Speziell wenn man Parameter in Sql Statements binden will. Unter php 7.1 klappt das ohne Probleme.

  6. #6
    Registriert seit
    Aug 2003
    Beiträge
    1.429
    Ja, damit haben wir aktuell auch Probleme.
    Wenn man das ganze ohne Klasse und Funktion macht, klappt es interessanter weise.
    Sobald ich (hoffentlich bald) den Support von Zend kontaktieren kann, möchte ich dieses Problem melden.
    Aktuell müssen wir auch noch mit php 7.1 arbeiten.

    Aja, beim einspielen der letzten IBM i PTFs, musste ich den Zend neun installieren, da aus irgendeinem Grund die binary Files kaputt gegangen sind.

Ähnliche Themen

  1. SAP on IBM i Summit 2019 am 25. und 26. Juni 2019 in Ehningen
    Von Christian Bartels im Forum NEWSboard SAP
    Antworten: 0
    Letzter Beitrag: 14-05-19, 09:41
  2. RDi-Lizenzierung
    Von Chris.jan im Forum IBM i Hauptforum
    Antworten: 33
    Letzter Beitrag: 20-03-19, 14:57
  3. Zend Server Sprache einstellen
    Von rr2001 im Forum NEWSboard Programmierung
    Antworten: 8
    Letzter Beitrag: 11-07-18, 08:09
  4. ZEND Performance
    Von Toschie im Forum NEWSboard Programmierung
    Antworten: 7
    Letzter Beitrag: 29-12-16, 07:29
  5. Zend Server auf IBM i - Kann nicht auf Server zugreifen
    Von msost im Forum IBM i Hauptforum
    Antworten: 7
    Letzter Beitrag: 04-11-15, 14:56

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •